开启辅助访问
 找回密码
 立即注册

文档显示是支持Ubuntu16.04的,现在我的arm开发板只支持Ubuntu16.04不支持Android...

时间:2018-10-25 阅读:550 回复:6

3

主题

7

帖子

42

积分

新手上路

Rank: 1

积分
42
本帖最后由 美好生活 于 2018-10-26 11:00 编辑

文档显示是支持Ubuntu16.04的,现在我的arm开发板只支持Ubuntu16.04不支持Android,去哪里获取支持Linux的ADK呢?





回复
使用道具 举报

15

主题

16

帖子

72

积分

版主

Rank: 7Rank: 7Rank: 7

积分
72
泰山| 2018-10-25 15:04:05 | 显示全部楼层
本帖最后由 泰山 于 2018-10-26 11:50 编辑

若派的神经网络计算棒,都是是可以提供X86 LINUX  SDK的,我也遇到你之前的问题,找他们的客服。

回复 支持 1 反对 0
使用道具 举报

3

主题

7

帖子

42

积分

新手上路

Rank: 1

积分
42
美好生活| 2018-10-26 11:11:25 | 显示全部楼层
本帖最后由 美好生活 于 2018-10-26 11:13 编辑

上个问题解决了,现在又有一个新问题,我现在已经拿到Ubuntu的ADK了,想在banannaPI的开发板上run起来,但是按照文档GTI2801_ADK_UG_v1-1.pdf去操作的话,在编译cnnSample的时候,报下面的错误:

图片1.png
目前我用的是Ubuntu 16.04,libc.so.6库包含了GLIBC_2.4的版本,但是还报这个问题就怀疑是不是你们的libGTILibrary-static.a库编译的时候用的是比较老的工具链和C库?还是其他问题啊?
   

回复 支持 反对
使用道具 举报
     

41

主题

46

帖子

204

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
204
若派人工智能| 2018-10-26 11:22:07 | 显示全部楼层
美好生活 发表于 2018-10-26 11:11
上个问题解决了,现在又有一个新问题,我现在已经拿到Ubuntu的ADK了,想在banannaPI的开发板上run起来,但 ...

是bananaPI支持的Ubuntu系统自带的C库的问题
回复 支持 反对
使用道具 举报

3

主题

7

帖子

42

积分

新手上路

Rank: 1

积分
42
美好生活| 2018-10-26 11:25:27 | 显示全部楼层
本帖最后由 美好生活 于 2018-10-26 11:26 编辑

好的,现在编译又碰到了一个跟GTI库有关的错误,如下图: 图片2.png

经过检查发现在ADK中GTGetUID(unsigned char*)函数没有定义。这问题该怎样解决啊?


回复 支持 反对
使用道具 举报
     

41

主题

46

帖子

204

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
204
若派人工智能| 2018-10-26 11:31:08 | 显示全部楼层
问题是ADK中的makefile没有链接-lGTI_checkvaild,导致没找到相关的函数实现。
回复 支持 反对
使用道具 举报

3

主题

7

帖子

42

积分

新手上路

Rank: 1

积分
42
美好生活| 2018-10-26 11:33:23 | 显示全部楼层
本帖最后由 美好生活 于 2018-10-26 11:34 编辑

我现在已经可以编译出cnnSample可执行文件了,但是执行的时候碰到个问题,如下图: 图片3.png

gti check error 4这里出错了,看代码是这个GtiInitialization(m_Device)函数执行的时候出错的,看你们的GTI2801_ADK_UG_v1-1.pdf文档说改下max_sectors为2048就可以解决这个问题了,但是我改了2048后,还是不可以,该问题依然存在。我现在用的usb2.0的接口。问题又出在哪了啊?


回复 支持 反对
使用道具 举报
快速回复
高级模式
B Color Image Link Quote Code Smilies |上传

本版积分规则

反馈意见:guohong.chen@searegal.com

客服电话:181-2986-7807

客服QQ:463716093

关注我们
登录 发布 快速回复 返回顶部 返回列表